Minimum System Requirements

SDL Secure Translation Supply Chain

Supported Operating Systems

  • Windows 7 Professional (Service Pack 1 or Later), with Remote Desktop Client RDP 6.1 or RDP 8
  • Windows 8 Professional (Service Pack 8.1 or Later), with Remote Desktop Client RDP 6.1 or RDP 8
  • Windows 10 Professional (Version 1703 or Later), with Remote Desktop Client RDP 8
  • Apple OS X (OS X El Capitan or Later), with Microsoft Remote Desktop application

Note: Remote Desktop Client RDP 7 is not supported by Windows 7 and Windows 8.

Internet Browser

The best user experience will be delivered via Windows 10 and Internet Explorer; please be aware that other operating system/browser combinations may experience additional login requests.

Support for Windows products, known issues, and workarounds are located here: https://technet.microsoft.com/en-us/windows/support-windows-10.aspx

We advise all computers connecting to the Secure Translation Supply Chain service are fully updated with all current Windows Updates.

Ready to log in to the secure environment?